Outage

Incident Report for Trackdrive

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 22:41 EST

Monitoring

The service interruption has been resolved, and performance has returned to normal. We’re monitoring the system to ensure continued stability.
Posted Nov 25, 2025 - 20:00 EST

Identified

We’ve identified the source of the issue impacting trackdrive and are actively working on a resolution.

Another update will be posted as soon as we make further progress.
Posted Nov 25, 2025 - 19:19 EST
This incident affected: Trackdrive Call Routing, Trackdrive Website & Account Interface, Trackdrive Call Reporting, Trackdrive REST APIs, trackdrive.com Incoming Calls - DID, trackdrive.com Outgoing Calls, trackdrive.com Recordings, plivo.com Incoming Calls - DID, plivo.com Incoming Calls - SIP, plivo.com Outgoing Calls, and plivo.com Recordings.