AWS US-East Outage
Incident Report for Trackdrive
Resolved
AWS has restored normal service.
Posted Dec 07, 2021 - 18:09 EST
Update
AWS Update:

[2:04 PM PST] We have executed a mitigation which is showing significant recovery in the US-EAST-1 Region. We are continuing to closely monitor the health of the network devices and we expect to continue to make progress towards full recovery. We still do not have an ETA for full recovery at this time.
Posted Dec 07, 2021 - 17:19 EST
Update
AWS Update:

[12:34 PM PST] We continue to experience increased API error rates for multiple AWS Services in the US-EAST-1 Region. The root cause of this issue is an impairment of several network devices. We continue to work toward mitigation, and are actively working on a number of different mitigation and resolution actions.
Posted Dec 07, 2021 - 15:48 EST
Update
Trackdrive continues to be impacted by the outage in AWS US-East. Because of the outage, TrackDrive is unable to launch additional servers. As a result TrackDrive's lead processing queue is falling behind the actions that are scheduled to be run in real time. We are observing delays in lead processing of around 1 hour at this time.

AWS has provided another update:

[11:26 AM PST] We are seeing impact to multiple AWS APIs in the US-EAST-1 Region. This issue is also affecting some of our monitoring and incident response tooling, which is delaying our ability to provide updates. Services impacted include: EC2, Connect, DynamoDB, Glue, Athena, Timestream, and Chime and other AWS Services in US-EAST-1. The root cause of this issue is an impairment of several network devices in the US-EAST-1 Region. We are pursuing multiple mitigation paths in parallel, and have seen some signs of recovery, but we do not have an ETA for full recovery at this time. Root logins for consoles in all AWS regions are affected by this issue, however customers can login to consoles other than US-EAST-1 by using an IAM role for authentication.
Posted Dec 07, 2021 - 14:39 EST
Update
AWS has provided this update:

We are seeing impact to multiple AWS APIs in the US-EAST-1 Region. This issue is also affecting some of our monitoring and incident response tooling, which is delaying our ability to provide updates. We have identified the root cause and are actively working towards recovery. We have identified root cause of the issue causing service API and console issues in the US-EAST-1 Region, and are starting to see some signs recovery. We do not have an ETA for full recovery at this time.
Posted Dec 07, 2021 - 13:27 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 07, 2021 - 11:52 EST
Monitoring
AWS is currently experiencing an outage that is affecting Trackdrive.

Update from AWS on the issue:

8:22 AM PST We are investigating increased error rates for the AWS Management Console.
8:26 AM PST We are experiencing API and console issues in the US-EAST-1 Region. We have identified root cause and we are actively working towards recovery.
Posted Dec 07, 2021 - 11:51 EST
This incident affected: Trackdrive Call Routing and Trackdrive Website & Account Interface.