AT&T Wireless Having Issues
Incident Report for Trackdrive
Resolved
AT&T said in a statement that it has now resolved the day's massive service outage:

"We have restored wireless service to all our affected customers. We sincerely apologize to them. Keeping our customers connected remains our top priority, and we are taking steps to ensure our customers do not experience this again in the future," the company statement said.
Posted Feb 22, 2024 - 15:47 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 22, 2024 - 11:12 EST
Identified
AT&T has an outage currently that is making calls to Leads using the AT&T network and buyers that are on the same. More can be be seen on:

DownDetector: https://downdetector.com/
CNN News Story: https://www.cnn.com/business/live-news/att-outage-02-22-24/index.html
Posted Feb 22, 2024 - 11:07 EST
This incident affected: Trackdrive Call Routing, trackdrive.com Outgoing Calls, and plivo.com Outgoing Calls.